Mustang and Ford Performance Forums banner
1 - 7 of 7 Posts

·
VMP Tuning
Joined
·
2,911 Posts
Discussion Starter · #1 ·
I had a kb 2.6l car on the dyno this afternoon, IC had no water in it, we filled it up and temps came back down, but the question is, where did the water go?

Have any of the ICs had problems leaking like the whipples?
 

·
Premium Member
Joined
·
647 Posts
We have a little to no failures with the intercooler cores. The are tested so 3 times before the final assembly then again after they are installed in the manifold. So we catch any failures before they are sent out. Did you lose any coolant after you filled it up? I hate to say it, but maybe someone didn't fill it up??
 

·
VMP Tuning
Joined
·
2,911 Posts
Discussion Starter · #3 ·
That was my first thought too, but the owner said he saw water in it before. The car only has 3000 miles on it. We'll see what it does over the next few weeks.
 

·
Registered
Joined
·
30 Posts
When I first installed my KB last spring I had coolant leak from the bottom IC hose connection. The KB installed spring clamp just wasn't doing the job. Replaced with a normal screw clamp and no problem since. My leak wasn't subtle at all. It made a big mess right away, but I suppose it's a possible source for a slower leak. Could drip on the plastic skid panel and run off where you might not notice it. Just a thought...
 

·
Registered
Joined
·
366 Posts
I had a similar problem with my KB 2.6 system. As it turned out, it was leaking at the hose connections going into the intercooler at the back of the intake manifold. I would bet a 100 bucks that is where it is coming from. I thru a little RTV on the barbs, and tightened the living snot out of the hose clamps. I had to pull the supercharger off the manifold to get to them, but it solved the problem. You might check to see if there is any fluids on the ground back by the trans. I haven't had a problem since I re tightened them.
 

·
"Do Work"
Joined
·
1,646 Posts
I'd check all of the hoses. When I did my first annital startup on my car, one of my hoses was leaking.. Just needed some RTV and to be a bit tighther and all the leaks went away.
 
1 - 7 of 7 Posts
Top