O2 sensors

+ Reply to Thread
Results 1 to 2 of 2

Thread: O2 sensors

  1. #1

    Default O2 sensors

    Having a problem with My 95 Mark VIII Idling rough and flooding after shut off. When I tried to read the voltage output at the connector it read approx 9 volts. All the reference books I read say that this voltage should be less than 1 volt. Wha is the correct reading at the connector?

  2. Remove Advertisements
    ModularFords.com
    Advertisements
     

  3. #2

    Default

    I know its late but maybe this will help some other people
    A oxygen sensor generates voltage up to around 1.5 volts at full rich going to the computer. A 3 or 4 wire sensor has battery voltage going to it for the heater.but can not cause a flooding problem. the first thing to check is put a fuel pressure gauge on it start it and run if i remember right its around 45 psi it should hold pressure over night. if it leaks down you have a fuel injector leaking. after that look at the coolant and air temp sensors can cause this problem after that your getting in to serious diagnosis.

  4. Remove Advertisements
    ModularFords.com
    Advertisements
     

+ Reply to Thread

Similar Threads

  1. Replies: 2
    Last Post: 03-19-2012, 11:24 AM
  2. 02 sensors
    By jrs in forum 2003 - 2004 SVT Mustang Cobra
    Replies: 8
    Last Post: 07-11-2010, 05:34 PM
  3. O2 sensors?
    By jivepepper in forum 1996 - 2004 Mustang GT
    Replies: 4
    Last Post: 12-26-2009, 10:45 AM
  4. What o2 sensors?
    By yellowstang1 in forum 1996 - 2004 Mustang GT
    Replies: 3
    Last Post: 04-30-2009, 07:53 AM
  5. o2 sensors
    By cbr in forum 1996 - 2004 Mustang GT
    Replies: 8
    Last Post: 08-08-2008, 03:45 PM