Lost Power

+ Reply to Thread
Results 1 to 3 of 3

Thread: Lost Power

  1. #1

    Default Lost Power

    Need some help anybody! I use a BS3 pro sefi in my car so factory engine harness was removed. I have lost power to the ignition, ie no lights, signals, starter, lamps etc while removing a previous nitrous install. How do I get power back to the ignition. I am thinking a wire from the engine bay fuse box but to which wire in the dash? any ideas? any body have a pdf of the helm schematic

  2. Remove Advertisements
    ModularFords.com
    Advertisements
     

  3. #2

    Default

    Joe Goffin has a digital copy of the of the Dealer Service Manual for the 03/04 Cobra's on his website. It is a downloadable version of the entire Ford Service manual including the Helm electrical manual and you can print out individual pages. Here is the link => http://www.terminator-cobra.com/svt_documents.htm. Scroll to the bottom of the page and you will see a heading named Service Manual. At the beginning of the Service Manual section's first paragraph you will see an orange Helms Service Manual icon. Click that icon and the download will begin.


    Ed


    p.s. Joe's site is probably the preeminent authority for Terminator information. It is a reference site so there is not posting but there is an umatched depth of information on the 03/04 Cobra's compared to anywhere on the internet. Go to his home page and explore a bit. I guarantee you've not seen anything like it, you will be wowed.
    Last edited by eschaider; 04-24-2018 at 03:56 PM. Reason: Spelling & Grammar

  4. #3

    Default

    Thanks ED! just what I need

  5. Remove Advertisements
    ModularFords.com
    Advertisements
     

+ Reply to Thread

Similar Threads

  1. could i have lost power???
    By niksnotch46 in forum 2003 - 2004 SVT Mustang Cobra
    Replies: 9
    Last Post: 10-07-2008, 10:29 AM
  2. car seems like it lost power?
    By GrecoGt in forum 1996 - 2004 Mustang GT
    Replies: 22
    Last Post: 06-22-2007, 08:28 AM
  3. Possible problems with engine, Lost power -.- HELP!!!
    By androdz in forum 2005 - 2010 Mustang GT
    Replies: 14
    Last Post: 03-27-2007, 12:43 PM
  4. Feels like I've lost power
    By 04cobra in forum 2003 - 2004 SVT Mustang Cobra
    Replies: 28
    Last Post: 12-18-2004, 10:19 PM
  5. Lost power swapping from 2.93 to 2.80
    By 78mphgpr in forum 2003 - 2004 SVT Mustang Cobra
    Replies: 17
    Last Post: 03-07-2004, 03:51 PM