Brand New 600hp short block. Thrust bearing failure 1k miles in - Page 2

+ Reply to Thread
Page 2 of 2 First 12
Results 16 to 17 of 17
  1. #16

    Default

    Quote Originally Posted by shipracer View Post
    ..... (and converter i just had the converter rebuilt new, for the new engine)..
    The above is where my question lies.. Unless I'm not understanding correctly this is a brand new, never used converter b/c it was rebuilt. If so, then it's reasonable that something was not made/assembled properly based on the trans it's going in.

    Before blaming the converter tho, I would definitely make sure the thrust clearance and converter clearances are spot on or a tad loose first but keep the above in the back of my mind.. I have a feeling that a stock flex plate and known good bearing clearance will fix the ordeal..

    ks
    Last edited by KEVINS; 01-14-2020 at 10:53 PM.

  2. Remove Advertisements
    ModularFords.com
    Advertisements
     

  3. #17

    Default

    I get what your saying with the TC. But it had 100k miles on it in this same transmission. Same TC builder that made it 100k miles ago. He knew what trans it's going in, and it was reliable for years.

    Plenty of people run this flexplate without issue.. and I only bought it because the engine builders recommended it. It was not purchased and part of the plan until they told me the stock ones are know to "grenade".

    This same TC builder opened and inspected it after the failure. Said nothing was broken, or off measurement.

    He could be lieing. But I don't think so. Plus I know his first build worked perfect for me. I trust him from my year's of experience using his product.

    And thank you man. I can't say it enough. Every reply someone does really helps the mental depression about the situation ha.

  4. Remove Advertisements
    ModularFords.com
    Advertisements
     

+ Reply to Thread
Page 2 of 2 First 12