Mustang and Ford Performance Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
First off I would like to thank doug at billet flow for helping me resolve the idle problem which was adjusting a the TPS voltage with the idle screw and also resetting the computer.

Heres the deal, my cats where not clogged and never glowed red after normal driving. After i put the KB on with the 55 lb injectors ,AT IDLE mind you, the cats are glowing red hot. Im not talking just a little hot I mean RED hot. I noticed the smoke of it coming from the engine bay, nothing seems to be burnt. I had shut the car on and off from 3,000 rpm idles about 10 times not all consistent but over a 30 min period. My first thoughts are that when i was messing with everything trying to get it to run right and while the after market chip was adjusting that it dumped a ton of fuel in there to do this AT IDLE, althought there where a few revs to 3,000 rpms, but not many. After all of this happened I taped the cats and knocked on them and heard no rattles like some say when the cats are clogged. Any responces would be greatly apprecaited. MODS INCLUDE: Kenne bell, 55 lb injectors/w harness, 12" K&N, bassani cat back, boost a pump, STOCK CATS.

BTW: Doug, sorry I did not respond to the other thread I just read it and I had to go to work shortly after talking to you.

I did not even buy anything from him and he was helping me out with a problem from something else. Now that is a great guy!!!!!!!!!!! Thanks again Doug.
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #4 · (Edited)
Hot Rod Harry said:
And I tip my hat off to Dougy boy for helping you out. He is da man! [/B]
Agreed!

But i was kind of hoping to fix the problem instead of going around it by having no cats. I do not think the cats are clogged simply because when i had the car before the KB the cats where fine. Now both of them are mysterously clogged? Not incenuating (SP?) that the KB is the prob. becuase if it is a fuel problem its more than likely the chip I had made from a shop here in town, but I do not know. Any opponions would be great!
 
G

·
Hmmmmm....check that tune...these KB's are tricky

Harry

boostin'03 said:
Agreed!

But i was kind of hoping to fix the problem instead of going around it by having no cats. I do not think the cats are clogged simply because when i had the car before the KB the cats where fine. Now both of them are mysterously clogged? Not incenuating (SP?) that the KB is the prob. becuase if it is a fuel problem its more than likely the chip I had made from a shop here in town, but I do not know. Any opponions would be great!
 
G

·
Thank you...glad I could help with you idle issue... thats what the boards are for.... (Stock TB BTW, for those that didn't get that)

Sorry I have no idea about your cats.
 

·
Registered
Joined
·
721 Posts
I'm no expert here, but you're adding more air and fuel to this engine now. I would think the exhaust flow would be increased as well. Maybe the stock cats can't handle the additional flow? Sure sounds like you're running rich though. Red hot cats at idle?

BTW, why are you still running the stock H with the Kenny Bell?

U.M.
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #8 ·
They are the stock cats. I heard the X-pipe has a funny sound to it and i liked the throaty sound of the h-pipe. I did not think that it would be bad to.
 

·
Registered
Joined
·
67 Posts
flow

I'm no expert here, but you're adding more air and fuel to this engine now. I would think the exhaust flow would be increased as well. Maybe the stock cats can't handle the additional flow? Sure sounds like you're running rich though. Red hot cats at idle?
Uncle meat said this.

In response; I think that you are right!!! But then I look back in my stang magizines to the test where they put the kenne bell on that stock cobra. They still had stock exhaust manifolds and cats. I just dont understand this. The article said nothing about burning up the cats. They had that thing dialed in and they were running some nice gas in it....I just think maybe your A/F is a little off. Im no expert but I just thought I would note to you that people have done it with stock exhaust and got away with it. I am curious as to what your A/F is right now.. Please fill me in and let me know when you find out.

Thanks, Andrew
 
1 - 10 of 10 Posts
Top