Mustang and Ford Performance Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
After putting new plug wires on the Stang I drove it around for a day

I notice some slight smoke coming from both exhaust mufflers (No pipe after muffler exit) As the car warms up the smoke gets worse, and just continuously puffs out smoke.

Has anyone experience this problem and does anyone know if my motor is toast or what??

The car is a 96 GT, Headswapped, and just about EVERY bolt on

The car hasn't lost any performance, it just emits smoke, I can still chirp the Nitto's shifting to third, and it seems the smoke only likes to come out at lower RPMS and idle

ANY HELP is greatly appreciated! :confused:
 

·
Registered
Joined
·
108 Posts
what did you...

...gap the plugs at ? what plugs did you buy ? check the PCV valve in the pass side cam cvr, plug it up and the hose and see if the smoke clears, could also be blow-by.

Randy
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #4 ·
Okay guys, thanks for the input

I pulled the plugs and regapped them @ .065 and installed 42000 volt screamin demon coil packs

The smoke persists....?

The #3 plug was COMPLETELY Black, all the other plugs looked fine

I replaced the #3, started the car and it was smoking just as bad if not worse than before

I replaced the PCV valve at the same time as the plug wire install

It came with some weird Add on piece that connects to the top of the PCV valve?? The piece pokes into the black air intake tube

Also, about the Blow By.. There is oil coming form the driver side valve cover and making its way into the intake tube???

Someone told me to check my Pro M MAF.. should I just pull it off and clean it??

THX yet again
 

·
Registered
Joined
·
138 Posts
clean the maf and also the actual tiny wires that will screw it up bad. Let us know what you find
 
1 - 5 of 5 Posts
Top