Mustang and Ford Performance Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I just installed a Kenne Bell Boost A Pump and I see no change in my fuel pressure. I wired it in just like the directions said but it still doesn't work. I also installed a Boost a spark unit which I installed wrong because Kenne Bell changed the instructions and didn't include a suppliment for the 03 Cobra. Has anybody else had a problem with the Boost A Pump? What can I try next?
 

·
Registered
Joined
·
140 Posts
my fuel pressure only went to 57 lbs at full boost not the 85 lbs like kenne bell instructions said..they told me the extra fuel pressure has to be gotten in the chip........when i first hooked it up the two wires were reversed but then the car wouldnt start going to the dyno today so we will see
 

·
Registered
Joined
·
57 Posts
The booster pump on my car would spike the fuel pressure to 100psi then immediately drop to back to stock pressure, after two days of that I have a fuel pressure transducer circuit failure trouble light on, and the car is pig rich. I'm waiting for parts to see what happens. Joe
 

·
Registered
Joined
·
758 Posts
KB BOOSTER PUMP FUEL PRESSURE

KB says the boost-a-pump will not work if you are not using his chip.

AMB
 

·
Snake Charmer
Joined
·
2,830 Posts
Re: KB BOOSTER PUMP FUEL PRESSURE

AMB said:
KB says the boost-a-pump will not work if you are not using his chip.

AMB
Really? I thought pete and some of the others were using the boost-a-pump and a diable delta and things are working fine?
 
1 - 6 of 6 Posts
Top