Mustang and Ford Performance Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
After reading a lot of info here and elsewhere I changed over to synthetics oils at 6000miles. Since then I am now hearing some sort of tick or piston slap or something, I'm not quite sure what.
It's especially evident at idle, although when the cars running, with normal road and engine noise is too loud to detect it.
The interesting part is I dont hear it when its cold, only once the engine warms up to running temp.
The engine itself seems to running very smooth and the car feels solid but I dont know what this tick/slap noise is?

Any ideas/suggestions would be appreciated


Thanks
 
G

·
Why not go back to what I use..the Motorcraft syn blend 5/20 and see what happens. I have heard this alot with Amsoil and Mobil One......might just be coincidence. But if I were you...I would go back to whatever you were using then.

Harry
www.HotRodHarrys.com
 

·
The Ubiquitous Jimmy V.
Joined
·
3,323 Posts
I would of thought the change would not create a Ticking sound.
I have used Mobil1 since second oil change and now 7K miles no hot tick.My engine like most is a little noisey on startup.
My 96 also was noisey on startup and i sold it with over 100K miles.I also only used Mobil 1 synthetic in my 96 Cobra.

jim v.
 

·
Registered
Joined
·
10 Posts
oil weight?

What weight oil are you using?. You probably want to use 5-20 / 5-30 or I think there is a 0-30 weight. I bought some Amsoil & a fliter to go with it, I haven`t put it in, I need to put some more miles on the car. The Amsoil dealer recomended ow-30, for the 03 cobras, good luck!!.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #5 ·
I used the Amsoil 2000 Series 0W-30 and the SDF-11 Amsoil Filter.


Hot Rod Harry,
whenyou said you have heard this a lot with Amsoil or Mobil1, what EXACTLY is the problem that it causes?

Sorry to sound so curious, I have no problem changing to anything that is good/better/best, just would like to have a basic idea why I might use a product or switch to a different one.

Thanks
Brett
 
G

·
Hi Brett...I really dont know..just from posts I have seen on the internet with our Cobra's. It might just be gossip and coincidence.
I havnt tried using any of them because of that...and so far no problems at all. I dont want to take the chance.

Sorry to alarm you ,
Harry
www.HotRodHarrys.com

snakin 69 said:
I used the Amsoil 2000 Series 0W-30 and the SDF-11 Amsoil Filter.

Hot Rod Harry,
whenyou said you have heard this a lot with Amsoil or Mobil1, what EXACTLY is the problem that it causes?

Sorry to sound so curious, I have no problem changing to anything that is good/better/best, just would like to have a basic idea why I might use a product or switch to a different one.

Thanks
Brett
 
1 - 6 of 6 Posts
Top