Mustang and Ford Performance Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
521 Posts
Discussion Starter · #1 ·
Installed the Billetflow Idler w/90mm pulley and AR filter lit(had UPR CAI), and drove for about 5 days. Car felt stronger, I guess it could of been all in my head, so I went by the dyno today and did a couple of runs. Don't have the graphs but last dyno was
Hot off the street: 451/476
1 hour cool down: 463/481
Today
Hot off the street: 438/453
1 hour cool down: 447/462

When I did the install, I disconnected the battery to zero the chip so it could re-learn the new CAI and Pulley(Idler). But that is all thats changed. I'm lost as to what could be causing this. All of my dyno's have been done on same dyno. Unlike last time however, I did notice that the boost drop I was getting at high RPM's is all but gone. Where I was seeing a 3lb drop, now it's more like 1lb maybe. Any ideas anybody? Any helpp would be appreciated....
 

·
Registered
Joined
·
2,573 Posts
03snake said:
Installed the Billetflow Idler w/90mm pulley and AR filter lit(had UPR CAI), and drove for about 5 days. Car felt stronger, I guess it could of been all in my head, so I went by the dyno today and did a couple of runs. Don't have the graphs but last dyno was
Hot off the street: 451/476
1 hour cool down: 463/481
Today
Hot off the street: 438/453
1 hour cool down: 447/462

When I did the install, I disconnected the battery to zero the chip so it could re-learn the new CAI and Pulley(Idler). But that is all thats changed. I'm lost as to what could be causing this. All of my dyno's have been done on same dyno. Unlike last time however, I did notice that the boost drop I was getting at high RPM's is all but gone. Where I was seeing a 3lb drop, now it's more like 1lb maybe. Any ideas anybody? Any helpp would be appreciated....
Post the graph with air/fuel so we have as much information as possible. It's hard to tell anyting without knowing how the air/fuel changed.

MJ
 

·
Registered
Joined
·
521 Posts
Discussion Starter · #3 ·
MJ, I wish I could but there is no wide band capability here on the Island. So I have no Idea what the A/F ratio is.
 

·
Registered
Joined
·
2,573 Posts
03snake said:
MJ, I wish I could but there is no wide band capability here on the Island. So I have no Idea what the A/F ratio is.
Too bad, I suspect that your air/fuel ratio might have changed and that is the reason for your drop in power.

MJ
 

·
Registered
Joined
·
521 Posts
Discussion Starter · #5 ·
As in got richer or leaner? Rick's tune should have had me pretty rich. Chip was tuned to see boost for a 2.80, but I was only seeing about 12-13lbs, now it's more like 14.5-15lbs. Taking the bend out of the intake should have leaned it up a little right?
 

·
Registered
Joined
·
2,573 Posts
03snake said:
As in got richer or leaner? Rick's tune should have had me pretty rich. Chip was tuned to see boost for a 2.80, but I was only seeing about 12-13lbs, now it's more like 14.5-15lbs. Taking the bend out of the intake should have leaned it up a little right?
It's really hard to say. Loss of power can be caused by running too rich or too lean. Can you post the dyno graph?

MJ
 

·
Registered
Joined
·
521 Posts
Discussion Starter · #7 ·
Yeah. I'll get a copy today and post. I'm thinking without the use of a wide band out here I probably should invest in one of your products maybe. Not sure if I'm smart enough to use it though.
 

·
Registered
Joined
·
2,573 Posts
03snake said:
Yeah. I'll get a copy today and post. I'm thinking without the use of a wide band out here I probably should invest in one of your products maybe. Not sure if I'm smart enough to use it though.
Sounds like getting your own wideband is a great idea. What I tell people is "if you can adjust the sliders on a stereo graphic equalizer you can tune with our products."

MJ
 

·
Registered
Joined
·
2,573 Posts
chillfactor said:
MJ good write up in MM&FF..........When he post his graph check for spark blow out. Just my 2 cents.
Thanks, the article was great except for the fact that they left out our web address. DOH!

I think that spark blowout might be an issue but since his peak torque dropped also and peak torque occurs way before these cars experience spark blowout (higher rpm range) that it is an unlikely cause. I would say that the most likely culprits are:

1. underhood intake setup is pulling in hotter air and the extra boost is making the intake air charge even hotter yet and the PCM sees this and pulls timing

2. his air/fuel changed

MJ
 

·
Registered
Joined
·
521 Posts
Discussion Starter · #12 ·
MJ, Chill, Sorry I haven't posted the dyno runs yet. I just finished a double shift i wasn't expecting and didn't get a chance to drop by the shop and pick it up. I did, however, come home to the UPS man, and got my Kooks LT's. I want to figure out this issue before I even think about puuting those on. As far as spark blow-out, I am running NGK-TR6's gapped about .37-.38. My untrained eye didn't see anything on the dynograph, but then again it's an untrained eye. I'll post it tomorrow. Thanks for the reply's. Later....BO
 

·
Registered
Joined
·
521 Posts
Discussion Starter · #13 ·
Chill/MJ, I still haven't gotten ahold of the graphs. However I did pull plugs yesterday. They seem to look good. Not much carbon, normal color all the way down inside and out. I went out to the track last night. Still running about 3mph slower than normal. Cooldown takes considerably longer than it used to. Thinking that it might have to do with changing CAI's and going with a straight filter setup instead of in the fender, I pulled right Headlight for more flow. Of course with the AFE filter it's closed ended, so not sure if it would have helped. No change in MPH. Stilll running 112-113. Used to run 115-116. Weather really hasen't changed.
 

·
Registered
Joined
·
661 Posts
Need to richen it up.
 

·
Registered
Joined
·
521 Posts
Discussion Starter · #15 ·
Pete, you think I went lean? From What? Taking the bend out of the intake or finding extra boost? I imagine you're referring to extra boost. I'm getting ready to install headers, and plan on re-tuning the chip any way...Thanks
 

·
Registered
Joined
·
521 Posts
Discussion Starter · #17 ·
Rick, I'll do that just as soon as I can get ahold of the chart. It's been either I'm working or the shop's closed. I'll try again today.
I'll be honest, I think it's heat related. I think boost is through the roof. When i get it, I'll e-mail it to you......
 
1 - 17 of 17 Posts
Top