Mustang and Ford Performance Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi all, I've been trying to track down an engine noise that sounds like lifter tick but have come to an end and not sure where exactly to keep looking, engine is a 97 block with 2000 pi heads, comp cams, BTR springs and retainers, new lifters, new ford gt followers, new timing chains and guides, new tensioners. But the noise is still present, I check out pressure out of the cam cap on passenger side, the driver side is a pain to remove the valve cover due to engine being in a 79 mustang. New Ford racing 4v oil pump as well.

Engine was running and sounding good then started tapping. I'm at a loss. Cold start oil pressure is 90 psi and hot idle is about 35 psi. Can someone point me in the right direction here please, engine sounds like a solid lifter engine.

 

·
Administrator
Joined
·
9,770 Posts
Try getting an automotive stethescope and checking likely locations. Once you identify the location discovering the source should be easy.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Been a while since I've been on here, but the issue I had was 2 broken valve guides and they were bouncing off the valve causing the tick, I had piston to valve issues on every single intake valve, I'm guessing the duration of the cams was too much for my setup or some type of valve float or lifter pump up. I just put some npi heads I had laying around on the engine and I'm back in business, put maybe 500 on the engine since swapping heads.
 
1 - 3 of 3 Posts
Top