Mustang and Ford Performance Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
684 Posts
Discussion Starter · #1 ·
was all pumped up got in to work today, predator is sitting at my desk. run to my car plug it in, loading, then says file not found???WTF??? tried many times but all the same results. called diablo up and they said that their policy is i have to send my unit to them first, and then have to wait for mine to come in, big bummer. no knock on diablosport, i understand that is how their policy works. but hopefully [email protected] will see this and somehow help me out. big thanks to RWTD to shipping it overnight for no charge though, still real excited to see what it will do before i do the pulley.
 

·
Registered
Joined
·
8,192 Posts
fioresvt said:
but hopefully [email protected] will see this and somehow help me out. big thanks to RWTD to shipping it overnight for no charge though, still real excited to see what it will do before i do the pulley.
Hey buddy! I'm sorry to hear about this, but not to fear, as I will have you taken care of tomorrow. I'll get you a new Predator overnighted, and shoot you over a pre-paid return label for the defective one you have.

Very Sincerely...
 

·
Registered
Joined
·
8,192 Posts
Phreakfree said:
NOW THAT'S SERVICE!!!
;)

That's just me! I fully believe in customer service and support, and I realize that it was because of my customers that have allowed me to be where I am today, so I must always give back at least 100% effort to them at all times!

Kind Regards...
 

·
Registered
Joined
·
684 Posts
Discussion Starter · #5 ·
thanks a million, i knew you would come through. now if you could teach a few other companies about customer service.
 
1 - 6 of 6 Posts
Top