Mustang and Ford Performance Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I am having some problems with the idle and with the engine over heating. The idle drops to approximately 500 RPM after you let off the gas. It will then return to 750. I bumped up the idle to about 800 RPM or so it works fine (no stalling but still drops first). After the inital drop in the idle it will idle just fine. However if I run the air conditioner the idle drops lower and it will stall more frequently. The engine also over heats with the air conditioner running. Has anyone else had this problem. Is it normal for the idle to drop to 500 rpms and then move back up to 750? Anyone had any problems with engine over heating with air conditioner on. Thanks.
 

·
Registered
Joined
·
11 Posts
Where are you located? There are a few I've read about overheating in Colorado. How did you set the idle? There's a process on setting the idle. You should probably take her in and have everything checked.
 

·
Registered
Joined
·
10 Posts
Killer Cobra said:
Where are you located? There are a few I've read about overheating in Colorado. How did you set the idle? There's a process on setting the idle. You should probably take her in and have everything checked.
I wonder if the people in CO with the problem have thought about the fact the radiator cap is a 16psi cap and the pressure differance at those elivations could effect it. Ford does have a special high altitude antifreeze that may not have been used. Just thinking out loud here. Am I making sence to anyone?
 
1 - 3 of 3 Posts
Top