Mustang and Ford Performance Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
I have completed my swap in my 99 gt only problem i have is the 2 sockets from the gt harness on the passenger side kick panel below the computer do not match up with 2003 cobra harness, im guessing these wires lead to the back of the car bc the fuel pumps do not turn on, does anyone know what i have to do? do i need to buy a cobra harness from these sockets backonce again im stuck and getting beat up by these problems
. thanks for any help.
____________________________________
 

·
Registered
Joined
·
848 Posts
You talking about the two green wires w/ (i think) a yellow stripe? If so you have to cut the connector off and ground one of them, doesn't matter which. Then you splice into another wire which I will have to look at mine to tell you which one. I'll try to check it out tomorrow.
 

·
Registered
Joined
·
848 Posts
Just so I know, which Cobra harnesses did you use and which ones are still Gt. Including the power distribution harness, the engine harness, ecm, ecm harness, and dash harness.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #4 ·
motor is 2003 cobra harness, and then harness to the pcm is 2003 cobra harness as well everything else is the gt harness
 

·
Registered
Joined
·
848 Posts
Ok, that's the way I did mine. Did you find all the changes that need to be made to the connector that mates the power distribution harness that runs across the rad support to the ecm harness? It connects under the air filter and is typically clipped on the top of the frame rail. I'll try to get pics today and make notes on all the splicing you'll need tonight.
 

·
Registered
Joined
·
360 Posts
Should stuck with the GT harness, you would've saved yourself a lot more money and headaches.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #7 ·
thanks man appreciate what ever info you can help me with......stuck with the gt harness for the motor??
 

·
Registered
Joined
·
360 Posts
thanks man appreciate what ever info you can help me with......stuck with the gt harness for the motor??
Keep everything from your '99 and modify the engine wiring harness to work with the 4V

You'll have to extend the wire for the COP's and i think maybe the Coolant temp sensor. I haven't completely finished up my wiring yet, but I have extended the COP wires for sure.
 

·
Registered
Joined
·
848 Posts
I did a side by side of the two harnesses and felt you would never get the same thing in the end. No IAT1 and 2. Only 1 which could be made into your IAT2, but that's not what Ford did. Hacking up the injector wiring looked to be a nightmare, and on and on.

So, here's what I did down by the computer.
#1. Find the two pin connector that has two green with yellow wires on the Cobra ecm harness. Cut one of those wires near the connector. Either one will do. Ignore the other one, it is rendered useless in this swap.

#2. There's a grey 14 pin connector that is flatter than the other grey connector. This connects the Cobra ecm harness to one of the Gt harnesses. On the Cobra connector there is a white wire. Cut it or remove it from the connector and ground it to the body right there. Cut the green w/yellow wire on the Gt side of the connector and connect it to the green w/ yellow wire that you cut in step #1. This will almost get your fuel pumps working.

#3. Run a 10 ga. power wire with a 30 amp inline fuse from the power distribution box around to the passenger side of the engine compartment near the hole where the ecm harness comes into the engine compartment (by the mass air meter). Fish out the light blue w/ orange wire out of the ecm harness, cut it and splice it to your power wire. You should now have power to your fuel pumps.
 

·
Registered
Joined
·
848 Posts
My battery is charged now so I'll get some pics tomorrow. I'll also go over the a/c connector, the oil pressure gauge and the connector on the frame rail I mentioned earlier. That should be it I think.
 

·
Registered
Joined
·
848 Posts
Oh, I forgot to ask. Does your green and white connector by the ecm connect to the Cobra harness? Some early model 99's don't.
 

·
Registered
Joined
·
848 Posts
If they don't then you should cut and splice the green and white 99 gt connector onto the Cobra ecm harness before you install it in the car. There is no room to work down there to solder them on. Sucks that the 2000 and up Gt's will work but the 99's don't.
 

·
Registered
Joined
·
848 Posts
I'll have to take all tape and looms off of the connectors in the engine bay to see what I did with them. Hopefully on Saturday I'll have some time after work.
 
1 - 17 of 17 Posts
Top