Mustang and Ford Performance Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I am running a 00 4.6 2v in my 92 LX with C.O.P . I am also running a Western Motorsports DFI unit. This unit requires I run a MSD DIS-4 . They tell me the computer they sent actually functions with a waste spark setup so I need only 1 MSD box. I understand that part, however they tell me I do not need a tach adapter, MSD says I do. The problem I have is the car has no spark. Will not running a tach adapter cause the car not to run? Also which tach adapter do I need and how many? Thanks
 

·
Registered
Joined
·
45 Posts
do you have a jumper plug? try using the jumper plug first. If the car starts.....your MSD is dead. At least you can rule the Bad MSD out.

pat
 

·
Registered
Joined
·
151 Posts
Tach adapters allow the Stock PCM to receive the correct signal so it will fire the injectors and coils correctly. So if SDS says it is not necessary it probably isn't and a car with DIS 4 will run without the tach adapters but missfire at higher RPMs.
Sounds to me like you may not have the wires connected to the coil power properly or perhaps the coil channels.
You could check all of the power wires defined in the MSD instruction booklet for voltage and all the grounds for continuity.
I would also say that you would have better luck using the 720 firing as far as ease of wiring and trouble shooting. But my question of this is...Does the SDS have the capability to use both?
Why not ditch the COP and run 320 firing with 4 tower coils? That may not be an option for you but would simplify things.
If I had a detailed schematic of the actual wiring you have done to compare to the manufacturers schematics it would help.
 
1 - 4 of 4 Posts
Top