Mustang and Ford Performance Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 ·
Hello everyone. Let's me start out by saying thanks to modular fords and everyone on here for the excellent knowledge and help this whole site has!

So I have a 02 mustang convertable gt and I just took off my p1sc procharger kit as I just broke in my new MMR 1000se longblock with it on 10psi. It made 550 rwhp through a 3650. I'm ready to make 1000+ rwhp. In doing so I finally got a hellion twin 64mm precision turbo kit, Th400 w/ transbrake, jw bellhousing, jw flexplate, jw crank adapter, b&m stealth shifter and lokar dipstick! I think I have everything to do it but have a few questions.

There's a big metal shim on the block from when I took off the 5spd. Does it stay or go?

The harness that's coming down by the stock tranny is for the 4 o2 sensors, reverse lights, and speedo correct? I deleted the 2 furthest 02 sensors cuz I installed a fast wideband. I read to attach speedo to abs or something, how do I do that? Also how do I set up reverse lights with new tranny and my stock wiring harness?

The bolts I got with the Bellhousing from jw are 10mm 1.5 45mm. Does that sound like the correct length? Also the look tapered before the head, the washers that came with the bolts go on the bolt until it tapers. They almost go on all the way but stop a half inch before the head.

I'm calling continental where I got my torque converter to see what he wants me to space the converter and flexplate at.

I will try and post pics right now
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #3 ·
So I got the th400 flexplate and converter all in. Waiting on tranny mount. Also got the jba shorties in. Should be working on installing turbo kit tonight
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #9 ·
So flexplate crank adapter and converter are all in. When the converter is all the way pushed in on tranny there's a 5/16 gap from converter to flaxplate. When I push converter towards flexplate it stops and bottoms out at 3/16 almost a 1/4. Is this normal?
 
1 - 9 of 9 Posts
Top