Mustang and Ford Performance Forums banner

1 - 20 of 28 Posts

·
Registered
Joined
·
2,357 Posts
Discussion Starter · #1 ·
I was told by some members not to use my cruise control as it will not work with the KB. On my way to a customer’s site this morning I decide to check it anyway and it worked perfectly. This was cruising at 80 mph for over 20 miles. At first when it was engaged for some reason it made the car leap forward, but after that it was fine. I was watching my boost/vac gauge and the vacuum stayed between 15-10 in hg the duration.
 

·
Snake Charmer
Joined
·
2,830 Posts
Jerry said:
Too funny... sounds like Accufab cars have the wrong throttle cable cam causing too much cruise control cable slack eh?

Jerry
If you look a little closer at Dustoff's sig you will see he has an accufab. It was easier to just get the accufab and KB at the same time from the same place. On a side note, And I have nothing against billetflow, but here is a thread to remind you that he is not perfect and had problems as well.

http://www.modularfords.com/showthread.php?s=&threadid=978
 

·
Registered
Joined
·
863 Posts
Yes Dustoff has Accufab with the Kenne Bell. Works fine ! No problems with it on my Eaton or KB.

And I have made several 100 mile + trips on highway with Cruise Control "ON"

My biggest problem with the Kenne Bell and Cruise Control is I want to drive it faster than the traffic around me so I am changing speed to often for cruise control. :D

JL
 

·
Registered
Joined
·
2,357 Posts
Discussion Starter · #10 ·
I have accufab TB as well.
 

·
Registered
Joined
·
459 Posts
Problem isn't with Cruise control all the time, its with initial engagement taking 1-2 seconds and then finally "catching" with a nice big driveline slack induced THUNK! Very unrefined. I too had issues w/ my BF TB (not going to do a link search but I'm sure you can find it if you want) and the point is Doug fixed them all. One of the problems I had w/ my BF (I had one of the first 5) was this exact problem. Point is if you have a BF I'd bet Doug fixes it and I think Mihovetz will as well. Bottom line is check into the stock vs. Accufab throttle cable cam and compare them to make sure they match and that there is little slack at best in your cables. If you find different angles or lots of slack you've found your problem with the cruise control initial engagement.
 

·
Senior Citizen Member
Joined
·
5,058 Posts
I do not have a KB, but did add the Accufab TB... do remember that my car had a slight surge when engaging the cruise even with the stock TB. Recall that most everyone will enjoy quicker throttle response with the big oval TB like the Accufab (or BF probably), so do you think that this plays a part ? I do. I feel a more pronounced initial engagement and, once in cruise mode, I can feel that the smallest movement of the controller to maintain speed leads to an over-compensation, again most prevalent on the speed increase adjustment. I just accept that the TB is the issue, and not that there is anything "wrong"... my $.02 !!!

Ratt Fink
 

·
Registered
Joined
·
2,357 Posts
Discussion Starter · #15 ·
HAMMER said:
Billet Accufab in mine.
Don't remind me Kenne-bell is now using selling the cheap casting units not the billet anymore.
 

·
Registered
Joined
·
374 Posts
Now that you guys mention, I did use my cruise the other day with my accufab and it acted wierd. I sped up to 80 and maintained speed. I set the acceleration and took my foot off the gas. Once I took my foot off the gas it decelerated for a moment then BAM. i'm in boost. It must of been 4 or 5 lbs for a second, but I was left wondering what the heck happened. Once it settled down it was fine. It happened a few times because I touched the breaks and reset the acceleration.
 

·
Registered
Joined
·
2,357 Posts
Discussion Starter · #17 ·
This is what I was told was the problem with cruise control not working.
 

Attachments

·
Registered
Joined
·
3,078 Posts
mine does the exact same thing, it has a bunch of slack. If I let off the gas quick the pedal sticks next time I press down on it. Whats the best way to fix this?
 

·
Registered
Joined
·
459 Posts
Call Accufab or get a BilletFlow, sorry but thats the only way I know to fix it. I guess you could get a custom cruise control cable to eliminate that slack as well but I know no cable manufacturers..
 
1 - 20 of 28 Posts
Top