Mustang and Ford Performance Forums banner

1 - 4 of 4 Posts

·
Snake Charmer
Joined
·
2,830 Posts
Discussion Starter · #1 ·
Ok got the car on the dyno but it wasnt good. When I installed BAP, I simply twisted wires together and hooked up a hand pump to the pressure switch to make sure voltage was rising with boost, then when I was sure it was working fine I soldered everything etc and ran boost switch up and connected it to actual vacuum line.

I got a stock 9psi pulley and a 17psi pulley. STarted the dyno run with the 17psi and BAP set to 40%. We had a scan tool connected to monitor fuel pressure (no fuel pressure gauge yet:(). We ended up aborting run early cause it was running too lean, we never say more than 43psi fuel and thinking maybe the delta switch chip was coded differently I switched from what was to be the 17psi setting to the 9psi setting and we attempted another pull. Same results, almost identicle A/F. Then lastly we turned switch to the "off" position and made another pull and it showed nearly the same thing again. We turned switch back to 17psi tune but this time We hooked a mechanical gauge to fuel rail, inside car scan tool never reported more than 43psi or so but mechanical gauge jumped to 90psi once fourth gear was hit and car was floored, then it immediatly dropped to 50psi or so and slowly started to move up when run was once again aborted do to lean A/F.

Lastly, since I had to pull chip I put 9psi pulley on and did a run with no chip. A/F was a tad higher than I would like but mirrored my baseline (ie no KB) pull. With just the KB and BAP set to 0, no chip it laid down 456 SAE corrected, but im wondering why A/F was so messed up with BAP turned up and chip installed.
 

·
Registered
Joined
·
140 Posts
im going back to diablo maybe tomorow if i get some time...patrick might have figured out how to get the fuel pressure up..did your a/f start to go higher at the end of the run??
 

·
Registered
Joined
·
85 Posts
mike5876 said:
im going back to diablo maybe tomorow if i get some time...patrick might have figured out how to get the fuel pressure up..did your a/f start to go higher at the end of the run??
Mike, do me a favor and shoot me a PM or email when you get back from DiabloSport. I will be there on the 16, 17, and 18, so please stop by and we'll shoot da sh!t.

Patrick tells me he's solved the FP issue; let's hope!

I'm sending you a PM now.
 
1 - 4 of 4 Posts
Top