Mustang and Ford Performance Forums banner

1 - 5 of 5 Posts

·
Snake Charmer
Joined
·
2,830 Posts
Discussion Starter · #1 ·
KB is installed and its simply amazing but one thing I noticed was after a little driving, car would idle at 1100rpm with a 9psi pulley (stock plugs, no chip installed and no BAP installed). I would have to blip the pedala tad to get it to ease down.

Once I was sure car ran and install/fluids etc all were good I put in IT 24's, 17psi pulley, BAP, and Petes diable tune. Car fired right up and idles like a champ, extremely responsive pedal and gobs of power which could be felt at 1/4 pedal(never got into it too much till after I get it on dyno). However, running at 17psi now when clutch was pressed in coasting to a stop it would idle at 2000rpm, even if I pulled over and sat idle would stay at 2k, blip the pedal once or twice and it would drop down to 700 or so, drive a bit normally and idle would hang again etc.

So, my question is, is this all part of the computers learning process? We did set it up so that it would not dump boost when clutch was depressed, would this affect it? Im a bit stump sinced the high idle seems to not be program related since it did it at 9psi with no chip and yet idled evener higher with a chip and more boost, almost seems like idle is boost related, but a blip or two of the pedal and you can get idle to drop......any ideas? We double checked all vacuum lines and connections, there are no codes or anything and car seems to be running flawlessly with ungodly amounts of power. SImply starting the car it will idle fine, it only holds a high idle during coasts to stops etc while normally driving.

I will have it on the dyno tomorrow night at 5:00 for some HP and A/F numbers but any ideas on idle issue would be greatly appreciated.

P.S. Is everyone else leaving theirs set up to dump boost like the stock setup or not?
 

·
Snake Charmer
Joined
·
2,830 Posts
Discussion Starter · #4 ·
The throttle is super touchy as well. I gave pete a call and he said it was just a weak spring and the amount of air being sucked in would hold the large single blade open ever so slightly. On his recomendation I simply added another small spring, pedel is much nicer and idle issue is gone.
 

·
Registered
Joined
·
90 Posts
The spring on the accufab does feel weak. When i had opened the stock tb by hand it had a lot of tension, but when I did the same with the accufab it felt weak.
 
1 - 5 of 5 Posts
Top