Mustang and Ford Performance Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,357 Posts
Discussion Starter · #1 ·
Those who have installed the KB know which one I am talking about. That damn bolt under the plenum I have spent at least 3 hours screwing with it and can't get it in. I was trying to use the one that came with the kit first and couldn't get it to budge and so I pulled it out and went with the factory bolt and same problem. The only addition thing is I can't pull it out. Overall the installation was cake other then this one major PIA. I now have everything done except for the bolt and the TB. I didn't do the TB for obvious reasons.

Any suggestions would be greatly appriciated.
 

·
Registered
Joined
·
90 Posts
Its alot easier to bolt the lower intake to the kb its easy to get to everybolt on there while off the car. Then take off the EGR valve and sit the kb/lower intake on there and bolt it down. Im surprised I am the only one to ever do that.
 

·
Registered
Joined
·
141 Posts
Actually, that bolt is a lot easier to install as the first one. That way you can lift up on the blower slightly while getting it started. Then use a pair of needle nose pliers to snug it down. After that, I cut off a piece of allen wrench about 1/2 inch long and used a 6mm ignition wrench to tighten it up the rest of the way. I didn't torque that bolt as per the instructions, just tightened it up good and tight. It might be possible with a 6mm crow's foot and a short piece of allen wrench. All in all, that bolt sucks, sure would have made things a lot easier if the plenum came off like the Eaton. Good luck, the end result is worth the effort, snakecharmr99.
:D
 

·
Registered
Joined
·
2,357 Posts
Discussion Starter · #4 ·
I finished it about an hour ago. Took it for a very short spin around my block just to see how it was running. The idle is a rough, but everything seems ok. The TPS is at .99 volts, but at wide open it is only reading 4.7 volts. That concerns me as I thought it should read 5.0 volts. The throttle cable is loose I will need to fix that also. I will need to take a second look at everything tomorrow.
 

·
Registered
Joined
·
31 Posts
Congrats man, Now you need to take me for another spin with the K.B.!!! And join me for some friendly runs...

BTW-Did you get the poished or satin version? And are you going to towers? Ohh and were are you getting it dynoed?

Thanks..hope everything works out.
 

·
Registered
Joined
·
2,357 Posts
Discussion Starter · #6 ·
SVT POISON said:
Congrats man, Now you need to take me for another spin with the K.B.!!! And join me for some friendly runs...

BTW-Did you get the poished or satin version? And are you going to towers? Ohh and were are you getting it dynoed?

Thanks..hope everything works out.
I have the black I think it looks better and really good on the car. I will probably hit Tower's on Friday. Now I am afraid to push it since I don't have a chip until I get a wideband run I don't know where I am going to go maybe razor's edge. I purchased the 9# pulley so I can run it without a chip until the predator comes out and then have it tuned to the 17# pulley.
 

·
Registered
Joined
·
250 Posts
I remember the infamous "bolt" coming up in a conversation with Pete. It had to do with the benefits of letting him do the install. I believe he said that he had the secret to taking care of that particular bolt. It would be another phone call, but it might be worth it to you.
 

·
Registered
Joined
·
2,357 Posts
Discussion Starter · #9 ·
predator said:
I remember the infamous "bolt" coming up in a conversation with Pete. It had to do with the benefits of letting him do the install. I believe he said that he had the secret to taking care of that particular bolt. It would be another phone call, but it might be worth it to you.
I bought it from Pete. I have the entire system installed and operational now.
 
1 - 9 of 9 Posts
Top