Mustang and Ford Performance Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Need help!!!

Have a LMAF on my turbo'd '01 GT and have a question. First, does anybody know the flowrate of this MAF and does anybody with a Autotap also have a log of maf flowrate and voltage?:confused:

It shows 327.8g/s (1180cfm) at 5v but I think this is wrong because the computer assumes a stock maf. So at 5v the stock maf would be that flowrate.

Problem is that this meter is pegging at around 4300rpm. This meter should be more than enough for my app but nobody seams to be able to offer any solution other than the meter is bad. But I know of someone else who is having the same problem on a turbo'd '01 Cobra from the same kit company.

Thanks:cool:
 

·
Registered
Joined
·
924 Posts
what's your location in Michigan maybe one of the guy's here on this site will let you borrow their MAf to see if your s is bad . Do you have a 80mm or 90mm MAF.
 

·
Registered
Joined
·
352 Posts
lou'sblk01gt said:
Need help!!!

Have a LMAF on my turbo'd '01 GT and have a question. First, does anybody know the flowrate of this MAF and does anybody with a Autotap also have a log of maf flowrate and voltage?:confused:

It shows 327.8g/s (1180cfm) at 5v but I think this is wrong because the computer assumes a stock maf. So at 5v the stock maf would be that flowrate.

Problem is that this meter is pegging at around 4300rpm. This meter should be more than enough for my app but nobody seams to be able to offer any solution other than the meter is bad. But I know of someone else who is having the same problem on a turbo'd '01 Cobra from the same kit company.

Thanks:cool:
Well has your tune been adapted to accept this 90mm MAF along with 42# injectors bro?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
The meter is a 80mm and I have a JMS Autologic chip. According to Chris J this meter shold not be pegging in this application.

I do have 42's but don't think this is really a tune thing. I'd really like to see what a voltage and flowrate log from a Lightning looks like.:cool:
 

·
Registered
Joined
·
467 Posts
I'd like to help you but I'm about to throw my AutoTap in the garbage. I need to call B&B and get it fixed, nothing worse than trying to log while making a pass and sitting in the staging areas screwing with it trying to get it to work.
 

·
Registered
Joined
·
173 Posts
Since you have an 01 GT, the clock speed of the processor is 24Mhz, and JMS should have imported the MAF curve for a Lightning 80mm MAF @ 24 Mhz. At 4.99v, the kg/hr rating would be 1567. FYI - stock 99-01 meters max out at 1180 kg/hr.

What kind of power are you making? I recently upgraded from a Lightning 80 to a 90. My 80 would peg hard, but I was able to tweak my calibration (I'm an Autologic guy) to dampen the lean trend and eventually control the A/F. Now, even with my 90, I'm still reaching upwards of 4.7-4.8v on my Procharged GT (420+ rwhp).
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
I dyno'd at about 370rwhp on a Dynojet with the boost dropping off (different issue) and running real rich. Similiar cars had done 400ish at 8-9psi.

With the car rich as it is, when the maf pegs it does lean out but is still rich!:D

I guess what confuses me the most is that Chris Johnson says it's not suppossed to peg, especially in a draw thru setup, maybe close in a blow thru. I'm probably going to buy a new maf to see if that makes any difference, they aren't that expensive.
 

·
Registered
Joined
·
173 Posts
What pump are you running? On your Autotap, record the "rail pressure sensor" and "injector duty cycle". With the Focus (aka Chicane) pump that I'm running, it's tailing off at 6000 RPM. You can watch the rail pressure start to fall and the injector pw start to increase exponentially.
 
1 - 9 of 9 Posts
Top