Mustang and Ford Performance Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I started my car yesterday for the first time in over a week, and a lot of water came out of the EX. More on the drivers side. I have never seen this much before. There was a good size puddle of water in the floor. It was cold outside, but the car stays in a heated garage. Any ideas? Is something wrong?
 

·
Registered
Joined
·
2,933 Posts
I started my car yesterday for the first time in over a week, and a lot of water came out of the EX. More on the drivers side. I have never seen this much before. There was a good size puddle of water in the floor. It was cold outside, but the car stays in a heated garage. Any ideas? Is something wrong?
Don't worry about it, likely no big deal.

--Joe
 

·
The Canadian Snowbra
Joined
·
1,847 Posts
I used to start my 4.6L Town car up, after it had sat in drastic temperature changes for a few days, and it would spew like a garden hose (literally) and barely run until I had blasted all the water out. Ran fine after that. I was told once that the 4.6's always dump a little bit out (clearly not garden hose quantities, but you see the point I'm making).
 

·
Registered
Joined
·
2,760 Posts
yea mine has spewed like a garden hose before also. Normal with these crazy temp flucs, don't worry about it. I actually had so much water in my exhaust one time that the car was sputtering. When I revved it up I gave my buddy a shower standing behind the car haha.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
Thanks guys for the info. Just wanted to be safe. Also the garage was heated at all times at 60 degres.
 
1 - 6 of 6 Posts
Top