Mustang and Ford Performance Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
492 Posts
Discussion Starter · #1 · (Edited)
Does anyone have any information here about the Mac Prochamber? I just bought one about 2 weeks ago and I am not liking it. Let me expain. After installing it and driving it, I noticed a big loss of low end, and cant say I noticed anything in the top end. Throttle response went to shit too. Well, I fiugred since I had a fairly modified car in which I had my Diablo chip Dyno tuned, it must need to be re-tuned (262 RWHP and 288 RWT). After fixing the initial exhaust leak at the drivers side header, I continued to notice what sounded like and exhaust leak, but couldnt find anything. I only notice it when the car is under load. Today I started the car, and I had a leak once again at the driver side header. I could smell exhaust fumes in the engine compartment. I loosened all the connections and readjusted it, making sure all was lined up. Tightened everything back down and started the car again. The sound was much less, but I could still smell exhaust in the engine compartment. The engine also shakes a little after initial pedal input when the rpms start to rise. I am at a loss here. Do you think I might have cracked the header? Maybe I should just go with longtubes and a shorty witch cats. Any help here would be greatly appreciated.
 

·
Registered
Joined
·
1,046 Posts
Did you have a catted pipe on before the swap?If so,you will need a new tune.Do you have a impact gun?Thats the only way sometimes to eliminate exhaust leaks.I could'nt get my Xpipe tight emough with a rachet..Once we hit it with the impact gun the exhaust leak stopped.

Did you put Mil eliminators on for the last to 02 sensors?They can make your computer act up.Have them turned off with your chip.

Tim
 

·
Registered
Joined
·
492 Posts
Discussion Starter · #3 ·
The pipes were originally put on with an impact wrench, only today did I tighten them with a ratchet. As for the Mil Eliminators, I did not put them on. Thats another story all togehter. After Putting the pipe on, then check engine light never came on. Not even a DTC for the O2 sensors. I played with it some, disconnecting them altogether, with the same result, no check engine light. So, I just reconnected them and never touched it again. I know my chip wasnt set to turn it off since I had cats on it before. Im about to say "TO HELL WITH IT" and get long tubes with shorty catted H pipe. Whats your opinion on that?
 

·
Registered
Joined
·
1,046 Posts
Longtubes and a shorty H would be a great combo!!!
Email Jason Kitchens or Turbo54 about your problem tho.I bet they can tell you exactly why your having the power problems.My guess is the 02's and your tune..But they are both dyno tuners so they could defineatly tell you the problem.

Tim
 

·
Registered
Joined
·
492 Posts
Discussion Starter · #5 ·
I was contemplating the thought of LT's and a shorty catted H, but hey want $950 for the BBK, and $800 for the Mac. Thats a little out of my price range.
 

·
Registered
Joined
·
6 Posts
I had the same problem with the exhaust leak problem. replace the stock manifold to h-pipe flange studs. the stock ones have a shoulder on them that prevent you from tightening the pipe down all the way.
I got my replacement studs without the shoulders on them from Napa Auto Parts (part #600-1819).
Leak stopped after I replaced them.
 

·
Banned
Joined
·
1,160 Posts
Not sure what model car you have or your mods, but the Prochamber is notorious for the leaking sound. From what I've researched, the sound you hear even after the exhaust leak fix, is typical of this pipe to sound that way.

My Prochamber has that same sound under load and I've come to believe it's just the sound that the stock pipe previously blocked.

I don't have any dyno numbers before/after, but seat of the pants, I didn't feel any loss of HP. And the car certainly feels strong as ever.

As for the smell, maybe you're just smelling the unburnt fuel and the fumes are coming from the rear? Mine has a very strong fuel smell that I've come to accept. It's the price I'm willing to accept without cats.

I'm not sure that you'll find another leak if you've double checked that header connection like you say. It hasn't burnt out the gasket on passenger side has it?
 

·
Registered
Joined
·
492 Posts
Discussion Starter · #8 ·
I recieved an Email reply finally from Mac. They said it was a known issue and sent me the instructions on how to correct it. I will post them when I get back home since I dont have the Email on this computer.
 
1 - 8 of 8 Posts
Top