Mustang and Ford Performance Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #1 ·
made 3 (almost) runs last nite details in hammer's thread on broken halfshafts...but real quick, run 1, blew tires off right away......2.03 60 ft, blew off tires on 2nd. and 3rd. gear changes........ran 12:3x at 118.xx mph..........second run left easy, slipped clutch at 3,000 rpm's and it bogged so hard it almost shut the motor off......2.01 60 ft. after that , clean powershifts, ran a much better 12:01 at 121.xx mph........really happy considering the huge bog.....3rs run heated the tires good, staged, slipped the clutch at 4,000 rpm's......left ok on a 1.85 60 ft.......pulled 2nd and bang....halfshaft failed....broken stub shaft on the amazon setup after 2 1/4 runs.....details in hammer's thread.......happy considering the conditions and just being a 2:80 upper only car:D
 

·
Registered
Joined
·
21 Posts
i was there last night running my mach 1. i saw you break im thinking of getting a cobra also but for now im just trying to get info on a chip to re-tune my mach 1 for all the mods ive done. any advise on who to get a chip from or should i go with my plan on taking my car to paul savinki in michigan?
 

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #3 ·
mach1 stuff......

I have done a few mach 1's my self and they respond well to chip mods, if you have any questions feel free to call me or stop by at the track next time and say hello
 

·
Registered
Joined
·
21 Posts
ok thanks ill come see you soon . sorry for your luck last night.
i have new axles and a auburn pro posi coming in on wednesday so im getting ready to rev her up and dump it, still waiting on my bogarts and slicks though.:evil
 
1 - 4 of 4 Posts
Top