Mustang and Ford Performance Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,497 Posts
Discussion Starter · #1 ·
Well I made it back in one piece, but still with a few problems. To start off with, the JT with the 3.33 pulley only made 13-14psi and the boost would not come on until on up in the RPMS. When it did come on, it came on really strong though. It was still a far cry from the 20psi I wanted/needed. We also were having a problem with the engine not wanting to rev much over 7000. The condition seemed to worsen as the dyno session went on. At this point I am not sure what it is, but everything I have checked on the engine looks fine (plugs, oil, water). I am pretty sure it has something to do with my ignition or coils. Anyway, with what boost we made we managed 587rwhp. The very next run it was making more power until it hit the point it busted up which happen to be lower than the 587 run. Chris and I both were pretty sure with a strong 8,000 rpm pull it would make 600rwhp, even with the boost being that low. My modded intake definately changed the power band and the power never did reach a peek. It was still climbing hard at the point at which it started haveing spark trouble. Now I will concentrate on getting my ignition problem straight and getting some track time in on it. Then maybe back to the dyno with 20psi or so before the shootout. On a side note the twin disk clutch performed flawlessly. I also have a few ideas to try on this setup once I get everything worked out.

Chad
 

·
Registered
Joined
·
207 Posts
Glad to see the Motor is holding together!!!!!

Go get some 9's and go 03 Cobra Hunting!!!! Bwaaaaaaaaaaa LMAO



:shocked



Jeff
 

·
Registered
Joined
·
204 Posts
Please keep us updated on the ignition problem. I am sure its the two pieces of speaker wire you taped together for your plug wires...you know you being a hillbilly and all :D
 

·
Registered
Joined
·
332 Posts
how did the intake affect the curve?

did it follow and then begin to make more? or was hp and torque lower in the rpm band and then begin to make more?
 

·
Registered
Joined
·
1,497 Posts
Discussion Starter · #5 ·
Compared to others I think the tqe peak was raised to higer in the rpm band and the HP seems to follow to 7K or so but not peak. Until the point of ignition trouble my cars power was still climbing. The lower tqe and late increase in power could be due to the large pulley (late comming in of boost) on the blower. I will be dynoing again with a smaller pulley once all is resolved.
 

·
Registered
Joined
·
302 Posts
What is your ignition set-up right now? Is this a common problem for big boost 4V's?
 

·
Registered
Joined
·
1,497 Posts
Discussion Starter · #7 ·
I think the problem was in the wiring that went to my MSD box. I now have a Kenne-Bell boost-a-spark and the problem seems to have went away. I will be dynoing again this Saturday with a much smaller pulley. I will post results ASAP.
 

·
Registered
Joined
·
332 Posts
Chad,

Were the numbers listed above on JMS's new mustang dyno or the dynojet he used to use?
 

·
Registered
Joined
·
1,497 Posts
Discussion Starter · #9 ·
Dynojet, his MD dyno was down for repairs. If all goes well we expect a consederable power increase this weekend.
 
1 - 9 of 9 Posts
Top