Mustang and Ford Performance Forums banner
1 - 20 of 28 Posts

·
Registered
Joined
·
2,769 Posts
Discussion Starter · #1 ·
My good friend Bob Trinanes went to the dyno the other day and got a little bit of dyno tuning done on his car. The car is equipped with twin Turbonetic T76's and made 1090 rwhp at 7300 rpms. He could not go further because he didnt realize he had the MSD switch in the wrong place. He saw 26 psi at 7300 and could have easily shut the dyno down if he would have reved it. Anyway this car is not legal for 4vpa class, but he'll be there to run open comp.


 

·
Registered
Joined
·
20 Posts
Thanks for the kind words, I do all the external work on the engine. I used a company called customtubes here in MA to do the plumbing for the turbos, Then a bunch of different companies for everything else.

Thanks
Bob Trinanes
 

·
Registered
Joined
·
21 Posts
Bob,

It looks awesome, and sounds like it is running the same. I like where you mounted the coil packs! Now lets see an electric water pump on that thing!

Tim
 

·
Registered
Joined
·
20 Posts
F8L SNK said:
Bob,

It looks awesome, and sounds like it is running the same. I like where you mounted the coil packs! Now lets see an electric water pump on that thing!

Tim
Thanks Tim, it does have an electric w/p, the stock one has the impeller removed (used for an idler).

thanks
Bob
 

·
Registered
Joined
·
21 Posts
I Stand Corrected, lol! I hope everything goes well. Have you made any runs yet, or are you waiting until after the shootout to release any #'s?

Good luck at the shootout by the way!

Tim
 

·
Registered
Joined
·
20 Posts
F8L SNK said:
I Stand Corrected, lol! I hope everything goes well. Have you made any runs yet, or are you waiting until after the shootout to release any #'s?

Good luck at the shootout by the way!

Tim
No runs yet except for driving it around town, I had a track rental for Wed. but it got rained out. So basically I'll be goin to the shootout kinda cold turkey, hopefully I can get the rest of the car dialed in there.

thanks
Bob
 

·
Registered
Joined
·
27 Posts
i want all you guys to read my signature. now that guy has immunity. :worship
 

·
Registered
Joined
·
24 Posts
Bob Trinanes said:
No runs yet except for driving it around town
HAHA I cant imagine driving a 1000+ hp car on the streets. Just think of the look on ricer boy's face when your already two lights down the street before he gets to 30mph. hahaha thats awesome!

Sweet car.
 

·
Registered
Joined
·
207 Posts
I saw it run [email protected] on sunday morning in TNT...I "heard" though that it spit out a rod shortly thereafter :jawdrop

John M told me that, so who knows LOL :hammer


congrats on the times Bob!!!


Jeff
 

·
Registered
Joined
·
20 Posts
Yes its true, I definantely broke a rod. Probably have to say its my fault I was warned that they could'nt handle the hp I was I was looking to dish out. The 8.50 @ 165 was with 26 psi and it went 130 mph in the 1/8th w/ 1.35 60 ft. When I turned it up a notch or two @ 30.5 psi every thing felt great until the top of second beginning of third when the rod broke. Kinda sucks but on a good note It went 138.7mph in the 1/8th with a worst 60ft of 1.43. I just pulled the motor and I 'm putting in another to catch FFW next month. Hopefully I'll be the the first 4.6 cobra in the SEVENS:lol

Thanks
Bob Trinanes
 

·
Registered
Joined
·
27 Posts
Bob Trinanes said:
Yes its true, I definantely broke a rod. Probably have to say its my fault I was warned that they could'nt handle the hp I was I was looking to dish out. The 8.50 @ 165 was with 26 psi and it went 130 mph in the 1/8th w/ 1.35 60 ft. When I turned it up a notch or two @ 30.5 psi every thing felt great until the top of second beginning of third when the rod broke. Kinda sucks but on a good note It went 138.7mph in the 1/8th with a worst 60ft of 1.43. I just pulled the motor and I 'm putting in another to catch FFW next month. Hopefully I'll be the the first 4.6 cobra in the SEVENS:lol

Thanks
Bob Trinanes
you are definitely the MAN! :worship2
 

·
Registered
Joined
·
142 Posts
Yes its true, I definantely broke a rod. Probably have to say its my fault I was warned that they could'nt handle the hp I was I was looking to dish out. The 8.50 @ 165 was with 26 psi and it went 130 mph in the 1/8th w/ 1.35 60 ft. When I turned it up a notch or two @ 30.5 psi every thing felt great until the top of second beginning of third when the rod broke. Kinda sucks but on a good note It went 138.7mph in the 1/8th with a worst 60ft of 1.43. I just pulled the motor and I 'm putting in another to catch FFW next month. Hopefully I'll be the the first 4.6 cobra in the SEVENS
Way to go !

Nice to meet you Bob !..To run as well as you did first time out is awesome. Good luck in the hunt for sevens.
Al

BTW.. If any of you were at the shootout and missed Bob's car..It looks even better in person...
 
1 - 20 of 28 Posts
Top