Mustang and Ford Performance Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
my car is bogging when i hit the gas. its usually only when the car is cold. and in normal driving situations. like normal rpm's. if i floor it, it stops bogging and takes off. to me it sounds like a miss or the fuel pump is takin a shit. any suggestions?
sounds like a lawn mower if i had to describe the sound. like its puttin along. it sucks. and it pops here and there. but like i said its only when the engine is cold. once it warms up it doesnt do it as bad and sometimes not at all.
 

·
Registered
Joined
·
89 Posts
my car is bogging when i hit the gas. its usually only when the car is cold. and in normal driving situations. like normal rpm's. if i floor it, it stops bogging and takes off. to me it sounds like a miss or the fuel pump is takin a shit. any suggestions?
sounds like a lawn mower if i had to describe the sound. like its puttin along. it sucks. and it pops here and there. but like i said its only when the engine is cold. once it warms up it doesnt do it as bad and sometimes not at all.
Doesnt really sound like the fuel pump....... I would expect it to have trouble reving if that were it....

Almost sounds ignition related.....
How old are the plugs/ wires??

Possibly o2 sensors...... How old are they??
Under cruize the computer relies on them for "normal driving"......
At wide open throttle.... the o2 sensors don't do much.....

I'm no expert here........
good luck
 

·
Registered
Joined
·
321 Posts
With what you said it sounds like it is maybe your MAF is dirty or going bad! Main reason I say that is cause of the popping and putting along. If it were plugs or wires it do it all the time, not just could but changing them could never hurt.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #8 ·
havnt gotten it fixed, it actually got worse. my car stopped the other day on my way to work, didnt let it warm up. it was boggin pretty bad. then it died at the light. then it wouldnt start. i checked the fuel pump relay fuse cause that had popped on me before. it was bad so i replaced it with one i had in my car. i went to startit and it didnt start. checked the relay again and its fine. thought it may be spark so i replaced the coil packs. still wont start.

some things about car, no imrc flaps. only bogged when i didnt let it warm up. has 115,xxx miles on it. has no cats and had the delete but melted and i need to find new ones.
 

·
Registered
Joined
·
508 Posts
Sounds like what my Blazer was doing. Cleaning the MAF took care of it for me but there can be numerous problems that lead to the same symptoms.

However, a can of CRC MAF cleaner is cheap. Its good to try the cheap stuff first.
 

·
Registered
Joined
·
56 Posts
I agree with sohcgt96 a dirty MAF would do that because on my dads Tbird when he changed the air filter and forgot to plug in the MAF it bogging out and jerking then it turned off.
 
1 - 10 of 10 Posts
Top