Mustang and Ford Performance Forums banner
1 - 14 of 14 Posts

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #1 ·
Got the Xpipe and MAC exhaust on friday night, car lost some tq but I thought it would pick up.

Got to the track today, thought the humidity wasnt gonna be that bad and it started gettin bad. Got up around 75% and temp was about 82 or so. So I thought I should of been able to match my previous best of 11.40 @122, I was wrong.

Lots of guys said the track was hooking hard, so I gave it hell. I didnt let the car cool off enough, and first pass out it went [email protected], so im like OK, its still hot a tad and mother nature could be playing a role here.

Next pass was an [email protected] 120. Then I let the car really cool off, maybe an hour or so, with some ice on the blower, fan on and IC pump going. It could of been cooler but I ran out of ice.

Pulled up into the lanes, did a nice burnout, launched the car at 4600 and it bit hard, so I went with it, everything was going awesome until the 3-4 shift which I missed. When I picked up my slip I was more pissed at myself than ever.

Im car #12 note: my previous 1/8th mile best was [email protected] on my 11.40 run, factor that into this run, and I think the car would of went 11.20's @122-124 or so. I coasted to an [email protected] arghhhhh on the missed 4th gear run



think the stock clutch is startin to show some weakness, when my car 60ftd hard today in the 1.6's I had trouble gettin into 4th. I have read some posts as well saying this happens when the clutch heats up.

I also still have the tune loaded for my catted stock Hpipe and catback piping, so I probably have some room in the tune as well, its probably rich.

Better luck next time. I did learn something. Icing helps, and heatsoak kills these cars. I knew soak killed em, but not that much. My car picked up 2mph and 2 tenths today from just letting it cool down all the way.
 

·
Registered
Joined
·
521 Posts
Man. nice 60'. I only dream of a 60' like that. But it's time to put the rumor to bed:
Is it or is it NOT, a bad idea to put ice on top of the Eaton. I've heard from this forum, although not lately, that putting ice on top of the Eaton, will cause the external casing to cool(shrink) faster than the internals, thus possibly causing damage. Is this a fairy tale or what. If it's not, I'm sure tired of waiting an hour or two just for the Eaton to cool a little bit. If anybody has some hard data on this, it would be appreciated. Thanks......
 

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #3 ·
I cant see it being that bad honestly. I use my IC Pump at the same time so coolant is cycling threw it and gradually bringing the temp of the internals and case down at once.

I guess I'll find out when mine comes apart, if it does? I guess you could also apply the same rule to when a car is hot and your turn it off on a cold cold day.
 

·
Registered
Joined
·
521 Posts
Whats a cold, cold day? LOL j/k I haven't seen one of those in about 7 years. Wait, thats not true, it did get down to 59 two years ago. But seriously, thinking about it, ice directly on top of the blower, I think I got this idea in my head from the lightning guys. The two or three I see at the track are firm believers of this. I olny found out about it, when I was approached at the track while I was putting a bag of ice on my Eaton. Can anyone else provide any info? By the Broke, those are some really nice times you're running, must be nice. Roll cage yet?
 

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #5 ·
No cage yet...i am suprised they havent approached me.
 

·
Registered
Joined
·
1,074 Posts
amazing times broke!! you must be one hell of a driver!! congrats on the new best!!:beer:
 

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #8 ·
I wish I could made a full run, im still frustrated at myself. That would be an awesome slip if it was an 1/8th mile track, but I will take what I can get. I hate posting up with "could of and should of" posts but It was on a good pass. I have a shifter to install and the tune to work on.

Later
 

·
Banned
Joined
·
2,034 Posts
Good job it hard to get the 60fts down with all this power I got a 1.55 on my 10.97 pass and I consistently put down 1.6's The summer is tough on fast times can't wait until fall.
 

·
Registered
Joined
·
898 Posts
I must just suck at driving...I would be happy with an 11 sec pass with my mods, yet broke get's a 11 after missing a gear!!!

God i can't wait until it gets cooler out and humidty isn;t 80+% everyday.

broke7, wanna give me some driving lessons?
 

·
Registered
Joined
·
459 Posts
broke7 said:
Got the Xpipe and MAC exhaust on friday night, car lost some tq but I thought it would pick up.

Got to the track today, thought the humidity wasnt gonna be that bad and it started gettin bad. Got up around 75% and temp was about 82 or so. So I thought I should of been able to match my previous best of 11.40 @122, I was wrong.

Lots of guys said the track was hooking hard, so I gave it hell. I didnt let the car cool off enough, and first pass out it went [email protected], so im like OK, its still hot a tad and mother nature could be playing a role here.

Next pass was an [email protected] 120. Then I let the car really cool off, maybe an hour or so, with some ice on the blower, fan on and IC pump going. It could of been cooler but I ran out of ice.

Pulled up into the lanes, did a nice burnout, launched the car at 4600 and it bit hard, so I went with it, everything was going awesome until the 3-4 shift which I missed. When I picked up my slip I was more pissed at myself than ever.

Im car #12 note: my previous 1/8th mile best was [email protected] on my 11.40 run, factor that into this run, and I think the car would of went 11.20's @122-124 or so. I coasted to an [email protected] arghhhhh on the missed 4th gear run



think the stock clutch is startin to show some weakness, when my car 60ftd hard today in the 1.6's I had trouble gettin into 4th. I have read some posts as well saying this happens when the clutch heats up.

I also still have the tune loaded for my catted stock Hpipe and catback piping, so I probably have some room in the tune as well, its probably rich.

Better luck next time. I did learn something. Icing helps, and heatsoak kills these cars. I knew soak killed em, but not that much. My car picked up 2mph and 2 tenths today from just letting it cool down all the way.
WOW, that is awesome! As far as the cllutch, looks like your waiting on Pro-5.0 install and you don't list an firewall adjustable clutch cable..I would bet if you did those two mods and adjusted the clutch to engage at the top of the pedal travel your missed 4th gear would go away. Tires/wheels: What are you using at the track?

Thx Jerry
 

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #13 ·
I got the pro-50 installed today, im ordering an adjustable quadrant later on this week, or I might borrow my buddies he hasnt installed yet. I like the pro-50 alot. I agree with you, I need to get the clutch up off the floor.

I use stock F1's on the front with stock rims. AFS stock replica's with bald ass 275/40/17 BFG Drag radials at 15psi.

Rage: where you at, im gonna be travelin down to the lower48 here this fall. Im from Louisville and will probably visit my parents back home in september. No car though, it stays here in alaska.
 

·
Registered
Joined
·
898 Posts
broke7 said:
Rage: where you at, im gonna be travelin down to the lower48 here this fall. Im from Louisville and will probably visit my parents back home in september. No car though, it stays here in alaska.
i'm in maryland, one of the furthest states away from alaska...
 
1 - 14 of 14 Posts
Top