Mustang and Ford Performance Forums banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #1 ·
Got the car dynod today.

Im not gonna say what the tune is like, all I will say is that its lean, way beyond what I thought it was. No pinging though. My previous dyno was 456/472 with stock Hpipe and catback piping with straightpipes, and a/f ratio was at 10.6:1 @ 6000rpm. It was in the Mid 13's to high 13's. Only thing changed was UPR offroad X and MAC 3" catback. Tune stayed the same, need to get some stuff richened up now.

Had some good observations on heatsoak and how hot temps affect a run. I iced the blower before the pulls. All 3 runs were done within 5-7 minutes. Temp was 75 degrees in the stall, and 30% humidity and barometer was at 29.8.

On the first pull with the car mildly warmed up and blower pretty cool it made 473whp / 495tq

2nd run
466whp 491tq

3rd run
457whp 490tq

So for all of you people wondering of iceing the blower works and cooling the car off between runs is worth it, close to 20whp was lost to heat in my case.

I think it has some more left in it if the car is infact being drug down by the lean condition. Very happy with my mod list. I also noticed at the top of my pulls around 6400 the HP and TQ curves started gettin jagged, which someone had mentioned was belt slip. Im gettin a gatorback and if that makes any difference. I am running a 74" NAPA/GAtes right now.

Couldnt ask for more.


:blob :blob :blob
 

·
The Ubiquitous Jimmy V.
Joined
·
3,323 Posts
Awesome Numbers..Get that AF straightened out..Lean is not good...
 

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #3 ·
Yah im gonna lay off the car till I get a reburn....thanks
 

·
Registered
Joined
·
250 Posts
WOW! Great numbers for the go-fast parts in your sig. I have been watching for your dyno results since the last time you posted about your exhaust changes. Glad to see you found your lean condition before you ended up with any problems. After your reburn it will be interesting to see how your numbers change.
 

·
Registered
Joined
·
246 Posts
Sweet numbers Broke! I answered in another thread what i believe gave you your lean conditions,make sure you check with your dyno guys about this because most likely you are not running that lean especially after you pulled your plugs and they looked fine.Let me know what you find out.
 

·
Registered
Joined
·
90 Posts
Great numbers broke 7!
Did you run the 11.25 with this tune? What does your plugs look like, any sighns of detonation?
I'm asking because i was running way rich before the X-pipe and was wondering weather i should have the Chip re-tuned? The car feels very stong and i don't wanna mess up a good tune!!
What should the Denso's look like under perfect coditions?

keep it up!

Riaan
 

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #8 ·
I ram 11.25 with this tune @ 123 multiple times now. Im still waiting on the reply from the dyno shop for info.

My plugs looked tan yesterday, little hint of grey but not lean by any means. I've never heard the slightest hint of ping or boggle on the top end under boost from this car, so I think that me be a whack A/F #
 

·
Registered
Joined
·
1,074 Posts
damn bro!!!! those are some good #'s !! congradulations!!
 

·
Registered
Joined
·
577 Posts
Sounds like you need the Heat Exchanger man, I did three back to back pulls on the dyno at JDM within 10 minutes and only lost 5rwhp and 8rwtq.....but then again you ARE in Alaska and 30% HUMIDITY...oh my....wish I could ship my car up there and give it a whirl or two on that dyno!!!!
 

·
Premium Member
Joined
·
5,466 Posts
Discussion Starter · #11 ·
Those were SAE corrected #'s though....havent got the graphs to see what the uncorrected were.

STD #'s were in the 490whp and 500tq area.

I dont think the heat exchanger could of done much for me. I think heat exchangers are a good mod, but for one run situations which is what I do, the stock one will suffice. I dont hot lap my car. I have gotten back after letting the IC fans run for 1 hour, and the coolant is still kinda cool after a low 11 second pass.

I think its more blower heatsoak than anything, not much you can do about that. Except KB
 
1 - 12 of 12 Posts
Top