Mustang and Ford Performance Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
492 Posts
Discussion Starter · #1 ·
Well, the SHM cams went in the car today with absolutely NO PROBLEMS whatsoever. No shimming, no nothing. Sounds GREAT, and very responsive, unlike the brand X they tried last time. So, for those who care, the car is finally done. Just waiting for the DYNO numbers which I will post later on after he's done tuning it. So far, SOOO GOOD :D Almost 9 weeks later, but its gonna be worth the wait.
 

·
Registered
Joined
·
307 Posts
Geeze. Making me get excited. Got a great deal on a set of comp cams bump sticks and having them overnited (should have them
Thursday) just so they can be installed and have the car running by the weekend. Hopefully I'll get it on the barrels next week for some much needed tuning.
 

·
Registered
Joined
·
492 Posts
Discussion Starter · #5 ·
Yes wld_wst, it's at JD's. Dyno was done late last night. Waiting to talk to him today. It's only 7am right now. The only thing I know so far is the car was very smooth and responsive on the first startup. A HUGE improvement over the previous attempts to get the OTHER set of cams to work. I should be going to pick it up around lunch time today. You work around there?
 

·
Registered
Joined
·
1,104 Posts
any dyno numbers yet?? Who did the head work???

Thanks

Jim
Team VT
:evil
 

·
Registered
Joined
·
492 Posts
Discussion Starter · #7 ·
L&M engines did the head work. Still waiting for them to run it on the dyno. Will post as soon as I get them. I want to post the actual graph as well.
 

·
Registered
Joined
·
492 Posts
Discussion Starter · #9 · (Edited)
Well, Im still waiting for the cars final results. At idle the car is fine. Slow to rev to 4K on the dyno, then revs normally. Wants to keep making power above 6K but they wouldnt rev it any higher on stock internals. They said it would probably make power to 7K or higher. The torque was lower than before the headwork. It looks like the cams are going to need to be degreed since the P&P took out the swirl dams and opened the ports up alot. Hoping to have results tomorrow (Sat) but Im not going to hold my breath. I would be dead by now if I did that.
 

·
Registered
Joined
·
492 Posts
Discussion Starter · #12 ·
Thanks for the link wld_wst. Let's see how Comp reacts when I talk to them monday with all that has happened with the cams they sent me, and the $ amount of what their cams cost me. When I get it back, we should hook up with some of the other LOCALS and cruise. I gotta baby it for a while after I get it back, so that all I can do is cruise. Is there any clubs around here that you know of?
 

·
Registered
Joined
·
740 Posts
stanggt00 said:
When I get it back, we should hook up with some of the other LOCALS and cruise. I gotta baby it for a while after I get it back, so that all I can do is cruise. Is there any clubs around here that you know of?
Sounds good bro anytime, but I don't really know of any clubs but there are a bunch of us who cruise in Delaware, here in PA, and some times Jersey.

Kev
 

·
Registered
Joined
·
307 Posts
Stanggt00--how did your run after the cam swap before a retune?
 

·
Registered
Joined
·
492 Posts
Discussion Starter · #15 ·
278 rwhp 285 rwt untuned. Pulled the 278 to 6K and was still climbing. He shut it down cause of the stock internals. He said it would have probably pulled to or above 7K.
 

·
Registered
Joined
·
307 Posts
stanggt00 said:
278 rwhp 285 rwt untuned. Pulled the 278 to 6K and was still climbing. He shut it down cause of the stock internals. He said it would have probably pulled to or above 7K.
Sounds good, but what I meant was how did the car idle? Did it surge etc. etc. until the computer was retuned?

Thanks,
 
1 - 17 of 17 Posts
Top