Mustang and Ford Performance Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
I installed the DC today for my first dyno pulls. I must first say that I was very impressed with the numbers gained with this IAC. BUT, on the way home (~3 hours drive) I noticed that I now have a tip in stumble/hesitation. Now, I forgot to unplug the battery when installing the DC to reset the ECM. Could this be a reason for the stumble? I also removed the MAF screen. Any ideas on this one guys?
 
G

·
I would say give the disconn batt try and then hook it up after you push on the brake pedal for abit to drain things down abit....I would leave it disconn for about 30 minutes just to be on the safe side...then start her up...dont touch the gas and let her idle for a bit....then take her out for a ride...dont get on her for awhile...and see what happens.

My dad has the same setup on his car and he loves it...with no probs...he has that and a steed catback exhaust.

Harry
 

·
Registered
Joined
·
3,322 Posts
There are an absolute blue million posts about the DC over on SVTPerformance. I think the standard suite of checks consists of:

1. Check for leakage around the MAF gasket.

2. Check that the gasket doesn't intrude into the MAF housing (visually or by feel); if it does, trim it.

3. I dumped the gasket entirely and used sensor friendly RTV to seal it, this may be worth a try.

4. If your filter is mounted in the 'down' position (2 90deg bends), consider changing to the 'up' position (1 90deg bend).

5. Contact Demolet and see if he has any further suggestions, he seems fairly responsive.


When I was trying the DC, I found that the more the computer 'learned' about the DC, the worse the stumble/rough idle/stall got. I got tired of messing with it, and got an Amazon kit. I've been happy ever since - all that stuff went away.

My 2 beans, HTH,
Bill
 
G

·
Wow....good thing I never bought a DC. I know they work good on a stock setup and slightly modified...but its just so much easier to use the plain old open striaght CIA setups that go out to the headlight opening.

I hear so many probs all the time with all these bends and such.

Harry
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #5 ·
I reset the ECM today and it runs fine now (knock on wood). I also installed my new Pro 5.0 shifter. Man, this car is fun now.
 
1 - 5 of 5 Posts
Top