Mustang and Ford Performance Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
Pete, Do you think it is a good or bad idea to swap the thermostat to a 180 or will that screw up my chip program? Will there even be a benefit? I just worried that the car won't run as well as it does now come warmer weather.
 

·
Registered
Joined
·
661 Posts
Yes a 180 is fine and will work with your chip, I think these cars come with a 180 , Mine did from the factory,
A 170 may be better I cant see it hurting, I will do that this week
thanks for bring it up , I forgot about it , Probably because of the cold weather, nitro
If you have a Q ask, I dont mind peace
 

·
Registered
Joined
·
661 Posts
Hey John, come to FL with us I have room ! nitro
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #5 ·
Thanks for the quick response guys.
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #6 ·
Is it worth it to buy one of those boost bypass kits?
 

·
Registered
Joined
·
661 Posts
Dont need it , The bump valve mod is good, I do them
nitro
 

·
Registered
Joined
·
38 Posts
JT said:
03's come with a 180.

JT
John - you sure? When i measured mine, it opened around 195. So did the "factory rated" one from NAPA.

??

On topic, I do not see the value in messing with the thermos - I think it is overrated and a remnant of the early closed loop days, I also see some potential downsides for street driven cars - for drag race only cars it is not a concern to run too cool. Ultimately, I believe that the end state of engine temp will be the same, based on flow rate, heat exchange capability (radiator), etc. A cooler thermo will just take longer to reach temperature homeostasis.
 

·
Registered
Joined
·
1,818 Posts
Yep, pretty sure. I judged from my OBDII scanner, water temp runs between 175-185.

Pete said when he removed his it had 180 stamped on it. Did yours have a stamping on it?

JT
 

·
Registered
Joined
·
38 Posts
Yeah, it did, and so did the NAPA unit, but they didn't open at that temp.

Anyway, I agree with your scan - the temps I am seeing match yours, and so i am not messing with the thermo.

But could it not be a 190 thermo, and still see those temps? Depends where you measure the coolant, correct? Is the ECT in the themo housing, or somewhere else?
 
1 - 10 of 10 Posts
Top