Mustang and Ford Performance Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Two issues:

1. There is a high pitch noise with a high frequency when I put the slightest bit of pressure on the clutch pedal. When I begin to fully engage the clutch, it goes away.

2. When coming to a stop, with the car in neutral, I hear a very pronounced noise. As if two pieces of metal are vibrating against each other. The clutch pedal has some vibration in it as well.

I am guessing that my throw out bearing and pilot bearing are gone. I am looking for some input
 

·
Registered
Joined
·
492 Posts
What mods are done to the car? When I put the Mac Prochamber on mine, I was getting vibration under certain torque loads through the shifter, and the clutch. Thought I had a problem with the tranny, and after 5 days at the dealership, they found that the driveshaft was making contact with the bracket that holds the O2 sensors. If you have done any exhaust mods, I would look at that being a possible cause.
 

·
Registered
Joined
·
100 Posts
Its interesting that this thread came up. I am hearing similar noises now....and was thinking the same thing about my tranny. I can definintley hear a whirring underneath and near the shifter when accelerating or decelerating, goes away when clutch is disengaged. I also hear a sort of ticking sound...I can hear that when the car is in nuetral and I just put some sideways pressure on the shifter. Im going to pull bezel and boot and check to see if my stop bolts have loosened up and are vibrating also. I did change gears a long while back but have never had any problems with them. I got 4.10's.
 
1 - 3 of 3 Posts
Top