Mustang and Ford Performance Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
I just got done installing long-tubes and a clutch. I started the car and I hear this metallic buzzing sound coming from the supercharger. The "whistle" comes back after five minutes but the buzz is still there. ANy ideas? thanks.

Pat
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
yep.....tried that. Someone was saying that it could be the idler pulley. Going to check that out this weekend. Thanks for the reply.

Pat
 

·
Registered
Joined
·
1,497 Posts
That was going to be my next suggestion. LOL When my belt starts going bad it makes a horrific noise. While you got the headunit off just spin it and double check to see if it has any noticeable damage.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #5 ·
Thanks, I am hoping it's not the head unit. If it is....I am fugged..:(
 

·
Registered
Joined
·
106 Posts
head unit

boom-boom said:
Thanks, I am hoping it's not the head unit. If it is....I am fugged..:(
If it is the head, it will cost you about $325.00 for new bearings at Vortech. They just did my S-trim. I didn't think that was to bad.
 

·
The Ubiquitous Jimmy V.
Joined
·
3,323 Posts
Vortech's always Problems:p
 

·
The Ubiquitous Jimmy V.
Joined
·
3,323 Posts
Re: say what?

96cobraman said:
But I had 80k on it. Do you think a Procharger will go that long?
80K no Problems :D I have them every day:mad:
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #11 ·
:lol
 
1 - 12 of 12 Posts
Top