Mustang and Ford Performance Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 ·
first of all id just like to say hello, i'm new here, but some of you might recognize me from stanget..

anyways, i've been having a problem with my 96 GT, weither the car is hot or cold, about 1/2 the time it starts just fine, cranks over 2 or so times then fires up.. but the other 1/2 the time the car cranks over anywhere from 10-30 times before it fires up.. i changed the plugs, made no diffrence, but i havnt had a chance to change anything esle, as i have been busy with moving into a new place, and school and work

any help would be appreciated
-Ryan
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #2 ·
also, the has developed a ping.. but only at highway speeds, below 60 mph, i can do anything i want, dosnt ping at all even right up near 6k... but once i'm driving on the highway, when i try and accelerate quckly(1/2 throttle or more) the car pings BAD, at any rpm above 2500 or so.. i have no idea what could cause this.. considering around town its fine


-ryan
 

·
Registered
Joined
·
89 Posts
You need to check fuel press. Install the gauge and then let it sit. Sounds like a bleed down issue and also could be low causing the pinging that you hear going douw the road. If that is fine then start looking at the maf. If you are running a k/n filter then you may need to clean the hot wires with some mild electronics cleaner and allow to dry before putting it in use. Tim
 
1 - 3 of 3 Posts
Top